久しぶりの更新がメモ!(笑)

先日、ご依頼があり、久しぶりにXoops Cubeを触りました。
テスト環境も作っておこう!と、まずはベースのXoops Cubeをインストール。

定番モジュールである「Altsys」や「Pico」もインストールしておこうとした際に、エラーが出て次に進めない…。

ぎゃー、なんでやねん!

というわけで、ハマってしまいましたよ。ええ^-^;

色々調べて解決に至ったのでメモ。

原因

MySQLのバージョンに問題があった。
というか、モジュール側の記述が原因と言った方がいいかも?!

解決策

インストールエラーが出る場合は、下記に着目。

TYPEになっているか、ENGINEになっているか

TYPE=MySQL
ENGINE=MySQL

TYPEという記述は、MySQLのバージョン4.0.2以前で使用していたコードだそうな。
最近のサーバは、MySQL5以上というのが定番になってきているので、ここの記述を書き換えてあげることで、インストールエラーを回避することができた。

よかったよかったヽ(*´∀`)ノ